De todo un poco

Todo sobre WiFi en WRT160NL con OpenWRT

with one comment

Aqui es donde comencé a configurar el router, perdí harto tiempo buscando cada una de las configuraciones que me parecian minimas acerca del WiFi. Veremos cómo configurar el router para ofrecer un Access Point, cómo configurarlo para conectarse a uno en Modo Cliente, cómo configurar un botón para apagar y encender el WiFi, y finalmente activar el led WiFi que viene desactivado por defecto.Instalando el WiFi y configurando un Access Point

El firmware OpenWRT no trae los paquetes necesario para la conexión con WiFi esto es porque se requiere de distintos paquetes según el dispositivo. En nuestro caso para instalar el WiFi primero debemos conectar el router a internet para poder descargar los paquetes, luego descargamos e instalamos los drivers y reiniciamos:

opkg update
opkg install kmod-ath9k
opkg install wpad-mini (este recomiendan instalar en OpenWRT.org)
reboot

Después de reiniciar el WiFi sigue deshabilitado, antes de habilitarlo generamos el archivo de configuración con algunos parámetros básicos:

wifi detect > /etc/config/wireless

Ahora hay que ajustar el archivo /etc/config/wireless en el cual borré la línea de la primera sección “radio0” para habilitar el dispositivo:

option disabled 1

y en la segunda sección “wifi-iface” configuramos el Access Point agregando las líneas:

option encryption psk2+aes
(más modos de encriptación en openwrt.org)
option key CLAVE
option ssid NOMBREAP

Guardamos, y finalmente activamos el WiFi con:

wifi up

Configurando el router en Modo Cliente

El router originalmente sólo se puede conectar a internet a través de un cable de red, pero ¿qué pasa si queremos que el router se conecte a internet a través de un punto de acceso WiFi? Entonces debemos configurar el WiFi de tal manera que sea un cliente de un punto de acceso A y a la vez ofrecer un punto de acceso B.

Primero debemos modificar la configuración para la interfaz wan en /etc/config/network cambiando el nombre del dispositivo de “eth1” a “radio0”

config interface wan
option ifname radio0
option proto dhcp

Después, debemos configurar el WiFi para que sea capaz de acceder un punto de acceso, para ello en /etc/config/wireless en la sección “wifi-device” fijamos el canal en el canal del Access Point al cual queremos acceder, en este ejemplo canal 1:

config ‘wifi-device’ ‘radio0’
option ‘type’ ‘mac80211’
option ‘channel’ ‘1’
option ‘macaddr’ ‘xx:xx:xx:xx:xx:xx’
option ‘hwmode’ ’11ng’
option ‘htmode’ ‘HT20’
list ‘ht_capab’ ‘SHORT-GI-40’
list ‘ht_capab’ ‘DSSS_CCK-40’

Luego, agregamos un nuevo “wifi-iface” con los parámetros del Access Point que le permitirán conectarse a él

config ‘wifi-iface’
option device radio0
option network wan
option mode sta
option ssid NOMBREAP
option encryption psk+tkip
(más modos de encriptación en openwrt.org)
option key CLAVE

Ahora basta reiniciar y el router intentará conectarse al punto de acceso al comienzo.

He tenido problemas con este sistema, después de grandes cantidades de tráfico el router se cuelga no quedando otra opción que reiniciarlo.

Configurar un Interruptor para el WiFi

Con éste método configuraremos el botón de WPS del router para apagar y encender el WiFi del dispositivo.

Primero creamos un script que apagará/encenderá el WiFi/Led, lo haremos ejecutable para más tarde simplemente llamarlo.

Creamos un archivo con nombre “woogle” (puede ser cualquiera, solo para ser consistente con lo que sigue) lo ponemos en el directorio /sbin con el siguiente contenido:

#!/bin/sh

case “$(uci get wireless.@wifi-device[0].disabled)” in
1)
uci set wireless.@wifi-device[0].disabled=0
wifi
echo 1 > /sys/devices/platform/leds-gpio/leds/wrt160nl:amber:wps/brightness
;;
*)
uci set wireless.@wifi-device[0].disabled=1
wifi
echo 0 > /sys/devices/platform/leds-gpio/leds/wrt160nl:amber:wps/brightness
echo 2 > /proc/diag/led/wlan
;;
esac

Lo hacemos ejecutable con el siguiente comando:

chmod +x /sbin/woggle

Ahora para que al presionar el botón de WPS en la parte frontal del router llamemos a este script usamos el modulo Hotplug, creamos un directorio en /etc/hotplug.d con el nombre “button” y en su interior un archivo llamado “01-radio-toogle” en el cual pondremos el siguiente contenido:

#!/bin/sh

if [ “$BUTTON” = “BTN_1” ] && [ “$ACTION” = “pressed” ] ; then
( sleep 1; /sbin/woggle ) &
fi

Ahora cada vez que queramos apagar el WiFi, bastará con presionar el botón del router o llamar el comando “woggle” a través de la consola.

Análogamente a éste método podemos crear un script que haga cualquier otra cosa al presionar el botón.

El botón reset corresponde al parámetro “BTN_0”, aunque veo poco práctico su uso.

Encender el Led de WiFi

Quiza nos hayamos dado cuenta que el led indicador de WiFi está apagado permanentemente. Para activarlo y hacer que pestañee con el tráfico simplemente debemos modificar el archivo /etc/config/system agregando una nueva sección “led”:

config ‘led’
option ‘name’ ‘WLAN’
option ‘sysfs’ ‘wrt160nl:blue:wlan’
option ‘trigger’ ‘netdev’
option ‘dev’ ‘wlan0’
option ‘mode’ ‘link tx rx’

Ahora bastará con reiniciar para ver los cambios.

Written by overside_

25.noviembre.2010 a 22.39

Una respuesta

Subscribe to comments with RSS.

  1. Perdona Pedro,
    Es que soy nuevo en redes y tengo este router pero no se como realizar los pasos que comentas, he intentado realizar telnet a la ip del router y conectar por putty pero no consigo nada. La verdad es que de unix tengo poca idea y si que tengo un pendrive con ubuntu pero no lo tengo disponible en este momento. Hay manera de acceder en modo comando al router y poder realizar los pasos que comentas. Mil gracias

    Jorge

    8.diciembre.2010 at 06.33


Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: